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WARRANTY

Tektronix warrants that the media on which this software product is furnished
and the encoding of the programs on the media will be free from defects in
materials and workmanship for a period of three (3) months from the date of
shipment. If a medium or encoding proves defective during the warranty
period, Tektronix will provide a replacement in exchange for the defective
medium. Except as to the media on which this software product is furnished,
this software product is provided “as is” without warranty of any kind, either
express or implied. Tektronix does not warrant that the functions contained in
this software product will meet Customer’s requirements or that the operation
of the programs will be uninterrupted or error-free.

In order to obtain service under this warranty, Customer must notify Tektronix
of the defect before the expiration of the warranty period. If Tektronix is
unable to provide a replacement that is free from defects in materials and
workmanship within a reasonable time thereafter, Customer may terminate the
license for this software product and return this software product and any
associated materials for credit or refund.

THIS WARRANTY IS GIVEN BY TEKTRONIX WITH RESPECT TO THE
LISTED SYSTEMS IN LIEU OF ANY OTHER WARRANTIES, EXPRESS OR

IMPLIED. TEKTRONIX AND ITS VENDORS DISCLAIM ANY IMPLIED
WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR

PURPOSE. TEKTRONIX’ RESPONSIBILITY TO REPAIR OR REPLACE
DEFECTIVE PRODUCTS IS THE SOLE AND EXCLUSIVE REMEDY

PROVIDED TO THE CUSTOMER FOR BREACH OF THIS WARRANTY.
TEKTRONIX AND ITS VENDORS WILL NOT BE LIABLE FOR ANY

INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES
IRRESPECTIVE OF WHETHER TEKTRONIX OR THE VENDOR HAS

ADVANCE NOTICE OF THE POSSIBILITY OF SUCH DAMAGES.





SOFTWARE LICENSE AGREEMENT

THE ENCLOSED OR ACCOMPANYING PROGRAM IS FURNISHED SUBJECT
TO THE TERMS AND CONDITIONS OF THIS AGREEMENT. USE OF THE

PROGRAM IN ANY MANNER, DOWNLOADING AND UNPACKING THE
PROGRAM FROM ITS COMPRESSED STATE OR INSTALLING THE

PROGRAM FROM A CD WILL BE CONSIDERED ACCEPTANCE OF THE
AGREEMENT TERMS. IF THESE TERMS ARE NOT ACCEPTABLE, THE

UNUSED PROGRAM AND ANY ACCOMPANYING DOCUMENTATION
SHOULD BE RETURNED PROMPTLY TO TEKTRONIX FOR A REFUND OF

ANY LICENSE FEE PAID FOR THE PROGRAM.

DEFINITIONS

“Program” means the software product (executable program and/or data) accompanying
this Agreement or included within the equipment with which this Agreement is packed.

“Customer” means the person or organization in whose name the Program was ordered.

LICENSE

Customer may:

a. Use the Program on a single machine;

b. Copy the Program for archival or backup purposes, provided that no more than one (1)
such copy is permitted to exist at any one time, and provided each copy of the Program
made by Customer includes a reproduction of any copyright notice or restrictive rights
legend appearing in or on the Program as received from Tektronix.

Customer may not:

a. Use the Program on more than one machine;

b. Transfer the Program to any person or organization outside of Customer or the
corporation of which Customer is a part without the prior written consent of Tektronix;

c. Export or re--export, directly or indirectly, the Program, any associated documentation,
or the direct product thereof, to any country to which such export or re--export is restricted
by law or regulation of the United States or any foreign government having jurisdiction
without obtaining any required U.S. and other government license, authorization or
approval;

d. Reverse engineer, disassemble, decompile or otherwise reduce the Program to a
human--perceivable form;

e. Modify, network, rent, lease, loan or distribute the Program or create derivative works
based on the Program; or

f. Copy the documentation accompanying the Program.



Title to the Program and all copies thereof, but not the media on which the Program or
copies may reside, shall be and remain with Tektronix or others from whom Tektronix has
obtained a respective licensing right.

Customer shall pay when due all property taxes that may now or hereafter be imposed,
levied or assessed with respect to the possession or use of the Program or this license and
shall file all reports required in connection with such taxes.

THE PROGRAMMAY NOT BE USED, COPIED, MODIFIED, MERGED, OR
TRANSFERRED TO ANOTHER EXCEPT AS EXPRESSLY PERMITTED BY

THESE TERMS AND CONDITIONS.

UPON TRANSFER OF ANY COPY, MODIFICATION, OR MERGED PORTION
OF THE PROGRAMWITHOUT THE PRIOR WRITTEN CONSENT OF

TEKTRONIX, THE LICENSE GRANTED HEREIN IS AUTOMATICALLY
TERMINATED.

TERM

The license granted herein is effective upon acceptance by Customer, and shall remain in
effect until terminated as provided herein. The license may be terminated by Customer at
any time upon written notice to Tektronix. The license may be terminated by Tektronix or
any third party from whom Tektronix may have obtained a respective licensing right if
Customer fails to comply with any term or condition and such failure is not remedied
within thirty (30) days after notice thereof from Tektronix or such third party. Upon
termination by either party, Customer shall return to Tektronix, or destroy, the Program
and all associated documentation, together with all copies in any form.

LIMITED WARRANTY

Tektronix warrants that the media on which the Program is furnished and the encoding of
the Program on the media will be free from defects in materials and workmanship for a
period of three (3) months from the date of shipment. If any such medium or encoding
proves defective during the warranty period, Tektronix will provide a replacement in
exchange for the defective medium. Except as to the media on which the Program is
furnished, the Program is provided As is without warranty of any kind, either express or
implied. Tektronix does not warrant that the functions contained in the Program will meet
Customer’s requirements or that the operation of the Program will be uninterrupted or
error--free.

In order to obtain service under this warranty, Customer must notify Tektronix of the
defect before the expiration of the warranty period. If Tektronix is unable to provide a
replacement that is free from defects in materials and workmanship within a reasonable
time thereafter, Customer may terminate the license for the Program and return the
Program and any associated materials for credit or refund.



THIS WARRANTY IS GIVEN BY TEKTRONIX WITH RESPECT TO THE

PROGRAM IN LIEU OF ANY OTHER WARRANTIES, EXPRESS OR IMPLIED.
TEKTRONIX AND ITS VENDORS DISCLAIM ANY IMPLIED WARRANTIES

OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.
TEKTRONIX RESPONSIBILITY TO REPLACE DEFECTIVE MEDIA OR

REFUND CUSTOMER’S PAYMENT IS THE SOLE AND EXCLUSIVE REMEDY
PROVIDED TO CUSTOMER FOR BREACH OF THIS WARRANTY.

LIMITATION OF LIABILITY. IN NO EVENT SHALL TEKTRONIX, ITS

RESELLERS OR OTHERS FROMWHOM TEKTRONIX HAS OBTAINED A
LICENSING RIGHT BE LIABLE FOR ANY INDIRECT, SPECIAL,

INCIDENTAL, OR CONSEQUENTIAL DAMAGES ARISING OUT OF OR
CONNECTED WITH CUSTOMER’S POSSESSION OR USE OF THE

PROGRAM, EVEN IF TEKTRONIX OR ITS LICENSORS OR RESELLERS
HAVE ADVANCE NOTICE OF THE POSSIBILITY OF SUCH DAMAGES.

THIRD--PARTY DISCLAIMER

Except as expressly agreed otherwise, third parties from whom Tektronix may have
obtained a licensing right do not warrant the Program, do not assume any liability with
respect to its use, and do not undertake to furnish any support or information relating
thereto.

GENERAL

This Agreement contains the entire agreement between the parties with respect to the use,
reproduction, and transfer of the Program.

Neither this Agreement nor the license granted herein is assignable or transferable by
Customer without the prior written consent of Tektronix.

All questions regarding this Agreement or the license granted herein should be directed to
the nearest Tektronix office.
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General Safety Summary

Review the following safety precautions to avoid injury and prevent
damage to this product or any products connected to it.

While using this product, you may need to access other parts of the
system. Read the General Safety Summary in other system manuals
for warnings and cautions related to operating the system.

NOTE. Refer also to the application online help for the General
Safety Summary specific to the application.

To Avoid Fire or Personal Injury

Connect and Disconnect Properly. Do not connect or disconnect probes
or test leads while they are connected to a voltage source.

Observe All Terminal Ratings. To avoid fire or shock hazard, observe all
ratings and markings on the product. Consult the product manual for
further ratings information before making connections to the product.

Terms on the Product. These terms may appear on the product:

WARNING. Warning statements identify conditions or practices that
could result in injury or loss of life.

CAUTION. Caution statements identify conditions or practices that
could result in damage to this product or other property.
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Preface

You can use information in this manual to install any application
from the Optional Applications Software for Windows-Based
Oscilloscopes CD-ROM (CD) onto your Microsoft Windows based
Tektronix oscilloscope. For compatibility information, refer to the
table on page 4.

Documentation and Online Help

This installation manual is part of a set of documents that you can
use to understand how to operate an application. For each applica-
tion, the CD contains the software, a PDF (portable document
format) file of each corresponding document, and the online help
formatted like a user manual.

PDF file
PDF file
PDF file

Optional Applications CD

Reference
(optional)

Online Help formatted
as a user manual

Installation
manual

NOTE. If you do not have an Acrobat reader to view a PDF file, you
can get a free copy of the reader from the www.adobe.com/products/
acrobat web page.
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The documentation set consists of the following items:

� This installation manual provides instructions on applying the
authorized Option Installation key label, installing an application
from the CD, enabling the application, and downloading an
application from the Tektronix web site.

� The optional application-specific reference quickly introduces
you to the steps required to take measurements and includes a
diagram of the menu structure.

� The Online Help contains the following types of information:

A Getting Started group of topics briefly describes the applica-
tion, lists oscilloscope compatibility, contains connection
procedures, and includes a deskew procedure, if required.

An Operating Basics group of topics covers basic operating
principles of the application. The sequence of topics reflects the
steps you perform to operate the application and includes
definitions for all menus and options.

A Tutorial group of topics that teach you how to set up the
application to acquire a waveform, take a measurement, view the
results, and save data to a log file.

An optional Application Examples (or laboratory) group of topics
includes examples of tests and measurements to give you ideas on
how to solve your own measurement problems.

A Reference group of topics includes the parameters (range of
values) for all options and the default values.

A measurement Algorithms group of topics with information on
measurement guidelines and on how the application calculates
each measurement.

An optional GPIB Command Syntax group of topics contains a
list of arguments and values that you can use with the GPIB
commands and their associated parameters. To show you how to
operate the application using GPIB commands, this part may also
contain a simple GPIB program.

� A printable PDF file of the online help formatted to resemble a
user manual.
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Contacting Tektronix

Phone 1-800-833-9200*

Address Tektronix, Inc.
Department or name (if known)
14200 SW Karl Braun Drive
P.O. Box 500
Beaverton, OR 97077
USA

Web site www.tektronix.com

Sales
support

1-800-833-9200, select option 1*

Service sup-
port

1-800-833-9200, select option 2*

Technical
support

www.tektronix.com/support

1-800-833-9200, select option 3*

6:00 a.m. -- 5:00 p.m. Pacific Standard Time

* This phone number is toll free in North America. After office hours, please
leave a voice mail message.
Outside North America, contact a Tektronix sales office or distributor; see
the Tektronix web site for a list of offices.
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Product Description

There are many applications available for Microsoft Windows based
oscilloscopes by Tektronix that you can use to test, to analyze, and to
debug many types of electronic devices and products. To learn about
most applications, you can browse the documentation folder on the
Optional Applications Software on Windows Based Oscilloscopes
CD-ROM and view any document listed. You can also access the
Tektronix web site for information on how to use an application to
resolve complex problems, such as an application note on how to
analyze jitter or an application note on how to verify compliance to a
serial data standard.

It is recommended that you upgrade your oscilloscope to the latest
firmware prior to installing or operating an application. You may
download the latest firmware from the www.tektronix.com website.
To do so, follow the instructions on page 20. Be sure to select the
firmware version appropriate for your specific oscilloscope model.

NOTE. Be sure to install the oscilloscope software before you install
any optional application software.

Application Upgrades

The Optional Applications CD contains all the current applications.
Some of these applications are offered as upgrades to previous
products. The following upgrades are available:

� TDSJIT3 V1 upgrade to TDSJIT3 V2 Advanced

� TDSJIT3 V1 Essentials upgrade to TDSJIT3 V2 Essentials

� TDSPWR2 upgrade to TDSPWR3

� TDSET2 upgrade to TDSET3
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TDSJIT3 V2 Advanced and TDSJIT3 V2 Essentials

New versions of the TDSJIT3 application have been released:

� TDSJIT3 V2 Advanced

� TDSJIT3 V2 Essentials

TDSJIT3 V2 Advanced offers significant improvements to the state
of the art jitter analysis. A new license must be purchased to enable
TDSJIT3 V2 Advanced beyond the five time free trial period. An
upgrade is available from earlier versions, please contact your local
Tektronix sales office or Tektronix account manager to order an
upgrade.

TDSJIT3 V2 Essentials provides capability similar to TDSJIT3 V1
Essentials and temporarily operates with either an option J3E or JE3
license key.

It is recommended that you upgrade to TDSJIT3 V2 Essentials or
TDSJIT3 Advanced to maintain the optimum performance for your
oscilloscope. Please contact your Tektronix sales office or Tektronix
account manager to order an upgrade.

This installation CD has both versions of TDSJIT3 available for
installation, however only the latest version, TDSJIT3 V2, is
available through the Installation Browser install menu. TDSJIT3 V1
must be installed by navigating to the proper CD folder and running
the appropriate setup file:

(cd_drive_letter:\Applications\TDSJIT3\setup.exe)

Please see the TDSJIT3 and TDSJIT3 V2 readme.txt files for further
information, instrument compatibility and system requirements.
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TDSPWR2 to TDSPWR3

The TDSPWR2 application has been replaced by the TDSPWR3
application and the TDSPWR2 application is no longer included on
the Optional Applications CD.

NOTE. The oscilloscope recognizes this upgrade only when the
TDSPWR2 application is enabled (Option Authorization key) prior to
the installation of the TDSPWR3 application. If you do not enable
the TDSPWR2 application before installing the TDSPWR3
application, you will only be able to run the 5-time free trials of the
TDSPWR3 application.

TDSET2 to TDSET3

The TDSET2 application has been replaced by the TDSET3
application and the TDSET2 application is no longer included on the
Optional Applications CD. To order an upgrade, please contact your
Tektronix sales office or Tektronix account manager.

Application and Oscilloscope Compatibility

The next table lists the applications included on the Optional
Applications CD with the compatible oscilloscope models and
firmware version numbers.

NOTE. To check the firmware version number of the oscilloscope,
select Help> About TekScope in the menu bar. Information will
appear that includes the firmware version.

If access is denied when installing software on Windows 2000 or
Windows XP operating systems, you may need administrator rights to
install.
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Applications on this CD and compatible oscilloscopes

Application name
Software
version Oscilloscope model

Recommended
firmware version

TDSCPM2*
Communications Pulse
M

V 1.2.2 and
above

TDS6604B, TDS6804B V 4.0.5 and above

Measurements
CSA7404B, TDS7154B,
TDS7254B, TDS7404B,
TDS7704B

V 4.0.4 and above

TDS5032B, TDS5034B,
TDS5052B, TDS5054B,
TDS5054BE, TDS5104B

V 2.0.5 and above

CSA7154, CSA7404,
TDS7054, TDS7104,
TDS7154, TDS7254,
TDS7404

V 2.5.3 and above

TDSDDM2
Disk Drive Measurements

V 1.3.2 and
above

TDS6604B, TDS6804B V 4.0.5 and above

CSA7404B, TDS7154B,
TDS7254B, TDS7404B,
TDS7704B

V 4.0.4 and above

TDS5052B, TDS5054B,
TDS5054BE, TDS5104B

V 2.0.5 and above

CSA7154, CSA7404,
TDS7054, TDS7104,
TDS7154, TDS7254,
TDS7404

V 2.5.3 and above

TDS5052, TDS5054,
TDS5104

V 1.2.1 and above

TDSDVD**
Optical Storage Analysis
d M

V 1.1.3 and
above

TDS6604B, TDS6804B V 4.0.5 and above
p g y

and Measurements
CSA7404B, TDS7154B,
TDS7254B, TDS7404B,
TDS7704B

V 4.0.4 and above

TDS5032B, TDS5034B,
TDS5052B, TDS5054B,
TDS5054BE, TDS5104B

V 2.0.5 and above
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Applications on this CD and compatible oscilloscopes (Cont.)

Application name
Recommended
firmware versionOscilloscope model

Software
version

CSA7154, CSA7404,
TDS7054, TDS7104,
TDS7154, TDS7254,
TDS7404

V 2.5.3 and above

TDS5032, TDS5034,
TDS5052, TDS5054,
TDS5104

V 1.2.1 and above

TDSDVI
DVI Compliance Solution

V 1.2.2 and
above

TDS6604B, TDS6804B V 4.0.5 and above

CSA7404B, TDS7254B,
TDS7404B, TDS7704B

V 4.0.4 and above

CSA7404, TDS7254,
TDS7404, TDS6404,
TDS6604

V 2.5.3 and above

TDSET3
Ethernet Compliance SW

V 1.2.3 and
above

TDS6604B, TDS6804B V 4.0.5 and above

CSA7404B, TDS7154B,
TDS7254B, TDS7404B,
TDS7704B

V 4.0.4 and above

TDS5032B, TDS5034B,
TDS5052B, TDS5054B,
TDS5104B

V 2.0.5 and above

CSA7154, CSA7404,
TDS6404, TDS6604,
TDS7054, TDS7104,
TDS7154, TDS7254,
TDS7404

V 2.5.3 and above

TDSHT3
HDMI Compliance SW

V 1.1.0 and
above

TDS6604B, TDS6804B V 4.0.5 and above

CSA7404B, TDS7254B,
TDS7404B, TDS7704B

V 4.0.4 and above

CSA7404, TDS7254,
TDS7404

V 2.5.3 and above
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Applications on this CD and compatible oscilloscopes (Cont.)

Application name
Recommended
firmware versionOscilloscope model

Software
version

TDSJIT3V2A
Jitter Analysis Advanced
and TDSJIT3V2E Jitter
Analysis Essentials

V 2.0.0 and
above

TDS6604B, TDS6804B V 4.0.5 and above

CSA7404B, TDS7154B,
TDS7254B, TDS7404B,
TDS7704B

V 4.0.4 and above

TDS5034B, TDS5054B,
TDS5054BE, TDS5104B

V 2.0.5 and above

CSA7154, CSA7404,
TDS6404, TDS6604,
TDS7054, TDS7104,
TDS7154, TDS7254,
TDS7404

V 2.5.3 and above

TDS5034, TDS5054,
TDS5104

V 1.2.1 and above

TDSJIT3
Jitter Analysis and
TDSJIT E Ji A l i

V 1.2.2 and
above

TDS6604B, TDS6804B V 4.0.5 and above
y

TDSJIT3E Jitter Analysis
Essential Measurements

CSA7404B, TDS7154B,
TDS7254B, TDS7404B,
TDS7704B

V 4.0.4 and above

TDS5034B, TDS5054B,
TDS5054BE, TDS5104B

V 2.0.5 and above

CSA7154, CSA7404,
TDS6404, TDS6604,
TDS7054, TDS7104,
TDS7154, TDS7254,
TDS7404

V 2.5.3 and above

TDS5034, TDS5054,
TDS5104

V 1.2.1 and above



Product Descriptions

Optional Applications Installation 7

Applications on this CD and compatible oscilloscopes (Cont.)

Application name
Recommended
firmware versionOscilloscope model

Software
version

TDSPWR3
Power Analysis
M

V 1.4.0 and
above

TDS6604B, TDS6804B V 4.0.5 and above
y

Measurements
CSA7404B, TDS7154B,
TDS7254B, TDS7404B,
TDS7704B

V 4.0.4 and above

TDS5032B, TDS5034B,
TDS5052B, TDS5054B,
TDS5054BE, TDS5104B

V 2.0.5 and above

CSA7154, CSA7404,
TDS6404, TDS6604,
TDS7054, TDS7104,
TDS7154, TDS7254,
TDS7404

V 2.5.3 and above

TDS5032, TDS5034,
TDS5052, TDS5054,
TDS5104

V 1.2.1 and above

RT--Eye�

Serial Data Compliance
V 1.1.2 and
above

TDS6604B, TDS6804B V 4.0.5 and above
p

and Analysis
CSA7404B, TDS7154B,
TDS7254B, TDS7404B,
TDS7704B

V 4.0.4 and above

CSA7154, CSA7404,
TDS6404, TDS6604,
TDS7154, TDS7254,
TDS7404

V 2.5.3 and above

InfiniBand Compliance
Module� (requires RT--Eye)

V 1.1.0 and
above

TDS6604B, TDS6804B V 4.0.5 and above

CSA7404B, TDS7404B,
TDS7704B

V 4.0.4 and above

CSA7404, TDS6404,
TDS6604, TDS7404

V 2.5.3 and above
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Applications on this CD and compatible oscilloscopes (Cont.)

Application name
Recommended
firmware versionOscilloscope model

Software
version

PCI Express Compliance
Module� (requires RT--Eye)

V 1.2.0 and
above

TDS6604B, TDS6804B V 4.0.5 and above

CSA7404B, TDS7404B,
TDS7704B

V 4.0.4 and above

CSA7404, TDS6404,
TDS6604, TDS7404

V 2.5.3 and above

TDSUSB2 for TekScope
Universal Serial Bus
M P k

V 1.8.0 and
above

TDS6604B, TDS6804B V 4.0.5 and above

Measurements Package
CSA7404B, TDS7154B,
TDS7254B, TDS7404B,
TDS7704B

V 4.0.4 and above

TDS5034B, TDS5054B,
TDS5054BE, TDS5104B

V 2.0.5 and above

CSA7154, CSA7404,
TDS6404, TDS6604,
TDS7054, TDS7104,
TDS7154, TDS7254,
TDS7404

V 2.5.3 and above

TDS5034, TDS5054,
TDS5104

V 1.2.1 and above

TDSUSB2 for PC�

Universal Serial Bus Mea-
surements Package

V 1.8.0 and
above

TDS694C V 6.0e and above
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Applications on this CD and compatible oscilloscopes (Cont.)

Application name
Recommended
firmware versionOscilloscope model

Software
version

TekConnect Adjustment
Application§

V 1.11 and
above

TekScope with TekCon-
nect devices

All

* Oscilloscope requires Option SM, Serial Masks, except CSA7000/B models.

** Can run on a personal computer (PC) connected to a compatible
oscilloscope; compatible with Windows 98 SE, Windows 2000, and
Windows XP operating systems.

� Requires Windows 2000 or Windows XP operating system.

� Can run on a PC connected to a TDS694C oscilloscope; compatible with
Windows 98 SE, Windows NT 4.0, Windows 2000, and Windows XP
operating systems.

§ For installation instructions, refer to page 19.
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5-Time Free Trial

A 5-Time Free Trial is available for all applications in the previous
table. You can start and exit an application up to five times to help
you evaluate Tektronix software solutions.

NOTE. If an application becomes available after you receive your
oscilloscope, you can download the new application as described on
page 20 to begin your free trials.

To start an application, refer to page 18.
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Application Installation

This manual contains information on the following tasks:

� Reinstalling a newer version of an application

� Installing an application from the optional applications
compact disc (CD)

� Applying a new label

� Enabling an application

� Starting an application

� Installing the TekConnect Adjust software from the optional
applications CD

� Downloading an application from the www.tektronix.com
web site

NOTE. Some applications may require a deskew fixture or a test
fixture. The application online help includes connection procedures
for these fixtures. If the application requires a fixture, read the
General Safety Summary in the fixture user manual before you start
the connection procedure.

Reinstalling an Application

Most available applications are factory installed on the hard disk in
the oscilloscope at the time the oscilloscope is shipped. The Optional
Applications Software on Windows Based Oscilloscopes CD-ROM
serves as a way to deliver applications to you that were introduced
after you received your oscilloscope, and as a backup in case you
have to rebuild the hard disk.

The optional applications CD may contain a newer version of the
application software than the version on your oscilloscope. The
www.tektronix.com web site may include an even newer version of
the application software than the version on the CD.
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Before you continue, determine if you need to reinstall a newer
version of the application. To do this, follow these steps:

1. In the menu bar of the TekScope window, select File > Run>
<application name> or App> <application name> as appropriate
for your oscilloscope.

2. In the menu bar of the application, select Help> About <applica-
tion>.

The application displays information about the application that
includes the software version number.

3. Check the version number of the application on the web site. To
do so, follow these steps:

a. Access the www.tektronix.com web site and select
Software & Drivers.

The Software and Firmware Finder page appears. To define
the search criteria, use one of the following methods:

� Make selections in the Browse by Product Category and
Browse by Product Series fields.

� Enter information in the Find by Model Number or
Keyword field. For example, Keyword Search TDSHT3.

b. Select Go. The search returns a list of software.

c. Scroll through the list to the desired application, select the
link, and view the web page instructions to download the
application to your oscilloscope. The version number is at
the top of the web page.

If the version number is higher than the version number in the
compatibility table (on page 4), then follow the Downloading
Updates Through the Web Site procedures on page 20.

The next table shows an example of how to check the application
version numbers and whether or not you need to reinstall the
application.
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Checking the application software version number example

Application on
the oscilloscope

As listed in the
table on page 4

As shown on
the web site Reinstall?

V 1.0.0 V 1.0.0 V 1.0.0 No

V 1.0.0 V 1.1.0 V 1.1.0 Yes, from the CD or
web site

V 1.0.0 V 1.1.0 V 1.2.0 Yes, from the web
site

Installing an Application

Normally, application software resides on the hard disk of your
oscilloscope. However, you may still need to install the application
software for the following reasons:

� You receive an application introduced after you received your
oscilloscope.

� You have to rebuild the hard disk of the oscilloscope.

� You download an update for an application from the
Tektronix web site.

NOTE. For information on how to install the TekConnect Adjust
application, refer to page 19.

Windows Based Oscilloscopes

The table on page 4 lists the available applications, compatible
oscilloscope models, and the corresponding software version and
firmware version numbers.

The installation procedure may require a mouse attached to the
oscilloscope.
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Application Introduced After You Received an Oscilloscope. To install an
application that does not currently reside on the hard disk of the
oscilloscope from the optional applications CD, follow these steps:

1. If the mouse is not installed, connect it to the oscilloscope rear
panel or use the touchscreen.

2. Power on the oscilloscope to start Windows.

3. Insert the optional applications CD in the CD-ROM reader.

The oscilloscope may automatically start the Installation Browser
program.

4. If the oscilloscope does not start the Installation Browser
program, follow these steps:

a. Select and open the My Computer icon.

b. In the Exploring - My Computer window, select the D:
(CD-ROM) drive and then the Launch.exe file.

5. Select the appropriate button for the application to install.

6. Follow the on-screen instructions given by the InstallShield
Wizard. Answer “OK” if prompted to install the JRE, accept all
defaults, and do not change the default directory.

The oscilloscope must reboot to complete the installation process.

Newer Version than the Application on the Oscilloscope. To install a
newer version of the application, you must first remove the version
that currently resides on the hard disk of the oscilloscope.

To remove the current version of the application software, follow
these steps:

1. Select File> Minimize in the menu bar to minimize the
oscilloscope.

2. Select Start> Settings> Control Panel> Add/Remove Programs.

3. Scroll through the list until the name of the application is
highlighted.

4. Select the Add/Remove button and follow the on-screen
instructions from the InstallShield Wizard.
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The oscilloscope must reboot to complete the removal process.

To install the newer version of software, follow the procedure on
page 14.

NOTE. If you install a newer version of an application than was
previously enabled, you do not have to enter the authorized Option
Installation key again.

Personal Computer (PC)

Some application software can reside on the hard disk of a PC
connected to an oscilloscope. The application controls the PC
through GPIB commands sent to and received from the oscilloscope.

First Time on the PC. To install an application that does not currently
reside on the hard disk of your PC from the optional applications CD,
follow these steps:

1. Power on the PC to start Windows.

2. Insert the optional applications CD in the CD-ROM reader.

The PC may automatically start the Installation Browser program.

3. If the PC does not start the Installation Browser program, follow
these steps:

a. Select and open the My Computer icon.

b. In the Exploring - My Computer window, select the D:
(CD-ROM) drive and then the Launch.exe file.

NOTE. The table on page 4 indicates which applications you can
install on a PC.

4. Select the appropriate button for the application to install.

5. Follow the on-screen instructions given by the InstallShield
Wizard.

The PC must reboot to complete the installation process.
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Newer Version than the Application on the PC. To install a newer version
of the application, you must first remove the version that currently
resides on the hard disk of the PC. To remove the current version of
the application software, follow the procedure for a newer version
than application on the oscilloscope on page 14.

To install a newer version of the application, follow the previous
procedure.

Configuring an Application to Operate on a PC. To run the TDSUSB2 or
TDSDVD application on a PC connected to an oscilloscope, you
must follow several configuration steps. The online help (OLH)
includes a procedure to configure your PC and oscilloscope prior to
starting the application on the PC.

You can view a PDF file of the OLH to access the procedure. To do
so, follow these steps:

1. Select Start> Programs> TekApplications> <application name>>
PDF. The corresponding PDF file displays.

2. Locate and follow the procedure to configure the PC and
oscilloscope.

Applying a New Label

You may need to apply a new authorized Option Installation key
label to the rear-panel of the oscilloscope for the following reasons:

� You purchase a software license to an application already
installed on the oscilloscope; the license allows you to enable
the application

� You upgrade the licensed application to a newer application

� You purchase an application introduced after you received
your oscilloscope

The label contains important information, such as the serial number
of the oscilloscope, options purchased for that serial number, and an
authorized Option Installation key number. Since each label is
unique, apply the new label over the existing one.
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NOTE. You do not apply a label on the TDS694C oscilloscope.

Enabling an Application

You must enter the authorized Option Installation key to enable all
purchased applications and product options on your oscilloscope.
The key is unique; it is specific to the serial number of the
oscilloscope and purchased options.

NOTE. You do not need to enable the TekConnect Adjust application
or any applications controlled by a PC connected to a TDS694C
oscilloscope.

Follow these steps to enter your alphanumeric key number:

1. If the oscilloscope powered on in the toolbar mode (default),
select the Menu button (upper right corner of the display) to put
the oscilloscope into menu-bar mode. In menu-bar mode you
should see a PC-style menu across the top of the display.

2. Go to the Utility menu in the menu bar and select Option
Installation.

3. Follow the on-screen instructions to enter the alphanumeric key
number exactly as it is printed on the rear-panel label.
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Starting an Application

To start an application, select File> Run> <application name> or
App> <application name> from the menu bar of the oscilloscope.

NOTE. You can view Online Help (OLH) topics from the oscilloscope
or a PC.

To view OLH topics from an oscilloscope, follow these steps:

1. Select Start> Programs> TekApplications> <application name>>
Help. The corresponding OLH system displays.

2. Use standard techniques to navigate through the Help topics.

You can view (and print out) a PDF file of the OLH formatted to
resemble a user manual from an oscilloscope. To do so, follow these
steps:

1. Select Start> Programs> TekApplications> <application name>>
PDF. The corresponding PDF file displays.

2. Use standard techniques (such as the File> Find search function)
to locate specific information.

To start an application on a PC (TDSUSB2 or TDSDVD applications
only) select Start> Programs> TekApplications> TDSXXX>
<descriptive name>.
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Installing TekConnect Adjustment Software

You must install the application on the hard disk of your oscilloscope
for the application to communicate with TekConnect devices. The
application software uses internal commands to validate test
hardware, and to communicate with TekConnect devices.

NOTE. The TekConnect Adjust application does not require the JRE
software and does not need to be enabled.

1. If the mouse is not installed, connect it to the oscilloscope rear
panel or use the touchscreen.

2. Power on the oscilloscope to start Windows.

3. Select File> Minimize in the menu bar to minimize the
oscilloscope.

4. Insert the optional applications CD in the CD-ROM reader.

The oscilloscope may automatically start the Installation Browser
program.

5. If the oscilloscope does not start the Installation Browser
program, follow these steps:

a. Select and open the My Computer icon.

b. In the Exploring - My Computer window, select the D:
(CD-ROM) drive and then the Launch.exe file.

6. Select the TekConnect Adjust button.

7. Follow the on-screen instructions given by the InstallShield
Wizard and reboot if recommended.

For a list of other adjustment procedures required for products with
TekConnect devices, refer to the service manual for your TekConnect
device. The service manuals are located in the documentation folder
on the CD.
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After installation, the Service Manuals and the application are
available on the oscilloscope from Start Menu>Programs>Tektro-
nix>TekConnect Adjust.

Downloading Updates Through the Web Site

You can find information about applications and firmware for your
oscilloscope on the www.tektronix.com web site. Click the Software
and Drivers link to download updates to the software and other free
applications.

NOTE. When updating an application, the Release Notes file on the
www.tektronix.com web site supercedes the Readme.txt file in the
web download self extracting.exe file.

Web Site Installation

To download an application to your oscilloscope or personal
computer, follow these steps:

1. Access the www.tektronix.com web site and select Software &
Drivers.

The Software and Firmware Finder page appears. To define the
search criteria, use one of the following methods:

� Select oscilloscope in the Browse by Product Category and a
product in the Browse by Product Series fields.

� Enter information in the Find by Model Number or Keyword
field. For example, Keyword Search TDSHT3.

2. Select Go. The search returns a list of software.

3. Browse to and select the link for your software.

Notice that the software link you selected includes other links to
view the Installation Instructions and the Release notes, plus the
version number of the application at the top of the page.
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4. Select the Download button and a MyTek Profile appears.

a. Log on to your MyTek Profile or create a new profile.
When finished, a File Download pop-up appears.

b. Select Save on the File Download pop-up, and then
specify a location to save to, for example, your personal
computer or oscilloscope desktop.

If you saved the downloaded file to your personal computer,
you may want to copy this file to a CD--ROM or a USB
memory device to transfer it to your oscilloscope.

5. To start the installation, double-click the .exe file and follow the
on-screen prompts. To complete the installation, reboot your
oscilloscope.
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